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Introduction

This document is designed to provide information about some of the trickier aspects of OpenOffice 
which you might need to master when creating technical documentation.

It includes:

information on current known bugs

workarounds for those bugs (if available)

procedures for tasks which aren't particularly intuitive

procedures for tasks which aren't possible using the GUI

Note

This document is designed with my current workplace in mind, so you may find it 
very lacking in some areas and info-heavy in others. It is a work in progress.

The information provided in this document is based on OpenOffice.org versions 2.0.3 to versions 
2.3.1.  Be aware that some of it may be outdated.

OpenOffice.org Manual

If you have the time and energy, read the Writer User Guide (available for download from the OOo 
website).
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Text Properties

Outline Numbering

Outline numbering (where numbers automatically appear in front of headings to denote the chapter 
number and level number(s)) is set up via the Tools menu. It is not set up in paragraph styles, 
although it is linked to specific heading styles.

Set Up Outline Numbering

This is designed for a 4-level outline numbered heading setup.

1. Go to Tools -> Outline Numbering...
2. Select 1-10 from the Level list.

3. Select Numbering Symbols from the Character Style drop down list

4. Select 1 from the Level list.

5. Select Heading 1 from the Paragraph Styles drop down list

6. Select 2 from the Level list.

7. Select Heading 2 from the Paragraph Styles drop down list

8. Select 3 from the Level list.

9. Select Heading 3 from the Paragraph Styles drop down list

10. Select 4 from the Level list.

11. Select Heading 4 from the Paragraph Styles drop down list

Refer to Heading Text in Header

To include the name of the current chapter in the header of each page (excluding the cover page):

1. Place the cursor where you want the heading text to be displayed.

2. Press Ctrl-F2.

3. Click on the Document tab.

4. Select Chapter from the Type list.

5. Select Chapter Name from the Format list.

6. Check that Layer = 1
7. Click on Insert.
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  Text Properties

Paragraph and Character Formatting

Read the Styles information in the OpenOffice.org Writer User Guide. Knowing how these work can be 
crucial to working successfully with technical documents in OpenOffice.org.

Tips for Working with Text Styles

Paragraph Formatting

If someone has added extra formatting to text (without modifying the paragraph style), the easiest way to 
get rid of it is to highlight the text, right-click and select Default Formatting. This (theoretically) resets the 
text to ONLY use formatting from the applied paragraph style. This method works better in later versions 
of OpenOffice.org.

Replacing Paragraph Styles

It may occasionally be necessary to change a large amount of text from one style to another – eg. Text 
body to Text body indent. Where the text is spread over a document, with other paragraph styles in 
between, the easiest way to achieve the change is a Find and Replace:

1. Press Ctrl-F.

2. Click on More Options.

3. Tick the Search for Styles checkbox.

4. Select the paragraph style you want to get rid of from the Search for drop down list.

5. Select the paragraph style you want to use instead from the Replace with drop down list.

6. Click on Replace All.
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Changing a Document's Template

Standard Document

Automated Process

Download and install this template changer extension for OOo Writer: 

http://extensions.services.openoffice.org/project/templatechanger

Manual Process

1. Select All.

2. Copy.

3. Create new document from correct template.

4. Paste contents into new document.

5. Save.

Master Document

Note

The template changer extension does not currently work for master documents.

1. Create new document from the correct template.

2. Send to new master document (File -> Send -> Create Master Document).

3. Save and close the new master document.

4. Make a copy of the entire file for the original master document.

5. Change the copy's extension from .odm to .zip.

6. Unzip the file to a new folder.

7. Change the new master document's extension from .odm to .zip.

8. Unzip the file to a new folder.

9. Find the content.xml file in the folder created when the copied original master document 
was unzipped. Copy it.

10. Paste it into the folder created for the unzipped new master document (this will 
overwrite a file).
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  Changing a Document's Template

11. Select all files in the unzipped new master document folder.

12. Zip all files into a new .zip file (overwrite the 'new master document' file).

13. Change the extension on the file from .zip to .odm.

14. Open the new master document file and check for problems.
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Creating a Master Document

Caution
When creating a master document, follow these steps only (the obvious 
method is buggy).

To create a master document:

1. Create new document from the correct template

2. Send to new master document (File -> Send -> Create Master Document)

3. Save and close the new master document
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Using Variables

Two actions are required for using variables in a document:

Set variable name and value

Show variable value

Important Note
Due  to  some  issues  in  OpenOffice.org  2.3.1,  I  started  declaring  most 
variables in a single subdocument. See Variables for more information on 
the bug.

Each variable is typically set once per document, either in a child document or on the cover page 
(underneath the graphic elements). 'Show variable'  can then be inserted throughout text in the 
document, and will change whenever the variable value is modified. See Referring to a Variable 
for more information.

Limitations on variables:

Cannot currently be inserted into text boxes.

Must be set before being shown.

Tip
Press CTRL-F2 to set or show references, variables etc.

Creating a Variable

1. Position the cursor where you want the variable to be placed.

2. Press Ctrl-F2.

3. Click on the Variables tab.

4. Select Set variable from the Type list.

5. Type the name of the variable into the Name field, and the current value in the Value 
field.

6. Click on Insert.
7. Click on Close, or create another variable.

Editing a Variable

Right-click on the set variable statement and select Fields.
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  Using Variables

Referring to a Variable

In the Same Document

1. Position the cursor where you want the variable text value to be placed.

2. Press Ctrl-F2.

3. Click on the Variables tab.

4. Select Show variable from the Type list.

5. Select a variable name from the Selection list.

6. Click on Insert.
7. Click on Close.

In a Different Document

When using master documents, you will frequently need to refer to a variable which is set in a different 
child document. The easiest method is to include a reference to each variable (each on a new line) – as 
above - and cut and paste the variable reference from the 'set variable' document to the other. It can be 
a pain – but it is far easier than replacing text throughout an entire document when a product name 
changes.

Tip
Enable View Fieldnames (Ctrl-F9) to make this process easier.
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Using References

References allow for dynamic links within a single document or master document. 

Note

This section refers to applying the CrossRef character style to all  links within a 
document. This is standard practice at my workplace, because it makes it clear to 
a reader as a link. You may, however, choose not to do so, or to use a different 
character style.

Creating a Reference

1. Highlight the text to use as the reference (note: this text will appear in the link).

2. Press Ctrl-F2

3. Click on the References tab.

4. Select Set Reference from the Type list.

5. Enter a name for the Reference in the Name field (this will usually be the same text as 
used for the reference, but must be unique – so the name may have to vary slightly from 
the highlighted text).

6. Click on Insert.

Creating a Link to a Reference - Same Document

If creating the link in the document where the reference was created:

1. Place the cursor where you want the link to appear.

2. Press Ctrl-F2

3. Click on the References tab

4. Select Insert Reference from the Type list.

5. Select a Reference to link to.

6. If you use chapter numbering in your headings, double-click on Chapter.
7. Double-click on Reference
8. Click on Close.

9. Place a space between the two reference links.

10. Apply the CrossRef character style to the links just added.
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  Using References

Creating a Link to a Reference – Different Child Document

The fields window will only display references created in the currently-displayed document. If creating 
the link in a different child document to that where the reference was created:

NOTE

The cross reference link  will  only  work  if  both documents are included in  the same 
master  document.  This  is  not  the  method  to  use  if  you  want  to  open  an  external 
document on a click.

1. In the same document in which the reference was created, find a place to put a temporary 
link.

2. Press Ctrl-F2.

3. Click on the References tab.

4. Select Insert Reference from the Type list.

5. Select a Reference to link to.

6. If you use chapter numbering in your headings, double-click on Chapter.
7. Double-click on Reference.

8. Click on Close.

9. Place a space between the two reference links.

10. Highlight and cut (Ctrl-X) the reference link.

11. Open the document in which you wish the link to appear.

12. Paste the link.

13. Apply the CrossRef character style to the links just added.

Editing a Link to a Reference

1. Right-click on the cross-reference and select Fields...
2. Select the format you want.

3. Click OK. 
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Using Captions

Captions are typically used before or after images and tables. They include the caption type (eg. 
Image), a unique number and a label (eg. Component Overview). Using a caption allows you to:

Create a table of references (with page numbers)

Create links to the caption (eg. see Image 2: Component Overview)

Create a Caption

There are two ways to set a caption for an object in Writer. The automatic option is obviously the 
easiest, but does have the annoying 'feature' of creating a frame for the object and caption while 
it's at it. If you're like me, you'll find this highly irritating. 

Once you've got one caption set up, you have the choice of redoing the process for each new 
caption, or simply copying and pasting. As long as numbering is set to increment automatically, this 
should work fine for most situations.

Automatic (Within a Frame)

1. Right-click on the object and select Caption.

2. Select a category or type in a new category name in the drop down list.

3. Enter text to be displayed after the caption category and number – this will typically be a 
unique description of the object.

4. Click on OK.

Manual

1. Press Ctrl-F2

2. Click on the Variables tab

3. Select Number Range from the Type list

4. Enter a category name (eg. Table, Image) in the Name field

5. Enter <category name>+1 in the Value field (eg. Table+1) if you want automatically-
numbered references. If not, enter a number)

6. Click on Insert. 

Link to a Caption

1. Press Ctrl-F2

2. Click on the References tab
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  Using Captions

3. Select the caption category from the Type list

4. Select your specific reference from the Selection list

5. Double-click on the link text desired (typically Reference).

6. Click on Close.

Create a Table of References for a Caption Category

1. Select Insert -> Indexes and Tables -> Indexes and Tables from the main menu.

2. Select Illustration Index or Index of Tables from the Type drop down list.

3. Select References from the Display drop down list.

4. Click on OK.
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Hidden Text and Paragraphs

Where a topic contains greatly different information, separate child documents are recommended. 
But sometimes only a relatively small amount of text needs to differ between documentation for 
different products. Where this is the case, hidden paragraphs and text can be used to show or hide 
product-specific text.

Caution
In earlier versions (2.0 – 2.1?) of OpenOffice.org, it was necessary to use 
User  Fields,  rather  than  variables,  on  which  to  base  hidden  text  and 
paragraphs. Those builds contain a bug which means that hidden text and 
paragraphs  based  on  a  variable  do  not  always  function  correctly  in  a 
master document. Variables should work correctly in OOo 2.3 and beyond.

Creating Variables

See Using Variables for information on creating variables in OOo Writer.

Creating User Fields

1. Place the cursor where you want to create a User Field.

2. Press Ctrl-F2.

3. Click on the Variables tab.

4. Select User Field from the Type list.

5. Enter a name and a value for the field (eg. Product and vm3).

6. Click on OK.

Referring to User Fields and Variables

To hide a paragraph or text if the document is being used for a specific product, use this syntax:

<User Field or Variable Name>==”<value>”

To hide a paragraph (or text) if the document is being used anything other than a specific product, 
use this syntax:

<User Field or Variable Name>!=”<value>”
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  Hidden Text and Paragraphs

Example

Product==”vm3” will hide the paragraph or text if the Product User Field is set to vm3.

Product!=”vm3” will hide the paragraph or text if the Product User Field is set to anything 
except vm3. If it IS set to vm3, the paragraph or text will be displayed.

Note the double = sign in the first option, and the use of double quotes.

Hiding a Paragraph

1. Place the cursor at the start of the paragraph.

2. Press Ctrl-F2.

3. Click on the Functions tab.

4. Select Hidden Paragraph from the Type list.

5. Enter a condition, using the examples above as a guide.

6. Click on Insert.

Hiding Text

1. Highlight the text to be hidden.

Note

Hidden text may only contain plain text. No character formatting or variables may be 
included.

2. Press Ctrl-F2.

3. Click on the Functions tab.

4. Select Hidden Text from the Type list.

5. Enter a condition, using the examples above as a guide.

6. Click on Insert.
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Paragraph Style Inheritance

To view the inheritance structure used in paragraph styles, open the Styles and Formatting window 
and select Hierarchical from the bottom drop down list.

This paragraph style inheritance structure is important, because it allows a font or size change to 
be made once and propogated throughout many styles. Unfortunately, it's also ridiculously easy to 
break in current versions of OpenOffice.

It IS possible to reset the inheritance structure by editing the  styles.xml file from an unzipped 
template. All settings which should be inherited must be removed from a child style.
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Setting Up Page Styles

Page styles can be tricky to get your head around, but are well  worth the effort. Why are they 
tricky? For two basic reasons – they're somewhat idiosyncratic, and they work differently to Word's 
page formatting.

The important thing to remember is that any time you want a page to look different to others in the 
same document, you'll need at least two page styles. 

Example

Ted has a fairly basic 10 page document. He wants the page number in the footer of 
every page except the first. On the first page, he wants no header or footer at all.

Ted should use two page styles. If he doesn't want to bother creating his own, he can 
use the standard ones which come with the normal template... First Page and Default. 
To set them up correctly, he should follow these steps:

1. Edit Default page style to display no header, but a footer.

2. Place the cursor on the first page of his document, after any text on the page, and 
insert a page break with the page style of First Page.

3. Insert a Page Number field into the footer of the second page.

View Available Page Styles

1. If you don't already have the Styles and Formatting window visible, press F11.

2. Click on the fourth icon from the left at the top of the screen.

The styles displayed are your current Page Styles.

Create a Page Style

1. Right click on an existing page style.
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  Setting Up Page Styles

2. Select New...

3. Enter a name for the style.

4. Have a look at the Next Style drop down list. 

This allows you to set a page style for the very next page after any with the new page style 
set. Confused? If you create a 'Cover Page' style, for example, you might be sure that it will 
only ever take up one page, and that you'll always want a 'Disclaimer' page straight after it. So 
you would set the Next Style to Disclaimer.

If, however, this page style will be for multiple pages in a row, you'll want to set Next Style to 
whatever you just named this new page style.

5. Click on the Page tab to set a page size.

6. To use a header with this page style (note: header will be the same for each page with this 
page style), click on the Header tab and tick the Header on checkbox.

7. To use a footer with this page style (note: footer will be the same for each page with this page 
style), click on the Footer tab and tick the Footer on checkbox.

8. Click on OK.

Edit Header and Footer

Unlike most versions of Word, this is simple. If headers and/or footers are enabled for a page style, 
they'll be visible in your document as boxes above/underneath the normal text area. Click inside to add 
text or fields.
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  Setting Up Page Styles

Add Heading Text to Header

You can see that this document displays the name of the current chapter in its header. For instructions 
on doing the same in your document, see Refer to Heading Text in Header.

Add Page Number to Footer

1. Place the cursor in the left side of the footer.

2. Press Ctrl-F2.

3. Click on the Document tab.

4. Select Page from the Type list.

5. Select Page numbers from the Select list.

6. Select a format for the page numbering  typically you'll want to make it As Page Style and 
make modifications in the Page Style options.

7. Click on Insert.

Change Page Style

Switching from one page style to another is simple:

1. Place the cursor at the end of the text for the last page of the current style.

2. Select Insert -> Manual Break from the main menu.

3. Select the Page break option button.

4. Select the new page style from the Style drop down list.

5. Click on OK.
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Troubleshooting

OpenOffice.org Crashes on Picture Arrangement

Occasionally OOo will crash when an image is moved backwards or forwards in the page structure. 
If the image is flickering – constantly redrawing – then a crash is almost inevitable if you atttempt to 
rearrange. One solution which seems to work is:

1. Right-click on the image and select Picture...
2. Click on the Wrap tab.

3. Select Through (even if it's already selected).

4. Click on OK. The flickering should stop now.

5. Attempt the arrangement again.

Variables

OOo 2.3 comes with an annoying bug – it will occasionally lose the value part of a set variable 
statement. Of course, this is only obvious if you look at the xml behind the document or master 
document. But the symptom is a show variable field which displays a zero instead of your variable 
value.

How to Fix Them

There are a few options:

Use an older version of OOo. 2.1 and earlier don't seem to have this bug. I'm not sure 
about 2.2.

Use a variable statement subdocument. This will NOT stop the problem from occurring, 
but it will make it a lot easier to fix. Set the variables in a document, insert the document 
in your master document, then edit the link (right-click on the file name in the navigator 
pane) – tick the Hide checkbox. The variable declarations will be invisible, but easy to 
edit. If the variables lose their values, you can re-insert them in the document.

Edit the content.xml and styles.xml files behind the document. See Edit the XML Behind
a Document for instructions.
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  Troubleshooting

Edit the XML Behind a Document

Accessing the XML

1. Make a copy of the entire file for the original master document.

2. Change the copy's extension from .odt (or .odm) to .zip.

3. Unzip the file to a new folder.

4. Open the folder just created.

5. Open the desired .xml file in an xml editor (I recommend XmlPad).

6. Format the xml code so it's easier to read (XML -> Format Document in XmlPad).

Check Variable Settings

Variable statements are generally found in the content.xml and styles.xml files.

1. Search for 'variable'. 

2. When you find a set variable statement, check for a value setting. If it's not there, then OOo 
doesn't know (anymore) what value to assign to the variable, which will be why it's showing up 
as 0. 

3. Check the type of variable it's set to. If it's set to “floating” or a numeric option, try changing it 
to “string”.

4. When you find a get variable statement, check for any text assigned to it (eg. <get variable 
[other info]>0</get variable>. You can edit a get variable statement to <get variable [other 
info]/> instead.

Get the XML Back to OpenOffice Document Format

1. Rezip the unzipped files and folders.

2. Change the zipped file's extension from .zip to .odt (or .odm)

3. Open it in OpenOffice.org to see how it looks.
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Keyboard Shortcuts

Some useful keyboard shortcuts are:

<ctrl-BACKSPACE> Deletes an entire word

<ctrl-shift-U> Adds an unnumbered line to a numbered list
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